Provya

Sécurité et téléphonie

Articles & Tutoriaux  -  Liens & Actualités

# - @ - Nicolas - 19/09/2018 à 15:54:07

Bonjour,

Super article, je vous invite à garder les menus et termes en anglais et proposer une traduction plutôt que de traduire directement. Il y a trop d'erreur de traduction pour que tout soit coherent dans une autre langue que l'anglais même dans la traduction officielle. Si les français veulent avoir des conceptes en français, ils n'ont qu'à les créer. AMHA

Concernant le problème que je voudrais résoudre: nous avons 2 WAN (WAN et WAN2) que nous voulons utiliser en fail-over. Nous avons également un range /29 d'IP publiques que nous voulons publier avec PFSense et faire du NAT 1:1 pour connecter des serveurs WEB, SIP et autres services.


L'accès Multi-WAN (2 xPPPOE) fonctionne mais comment paramètrer les IP virtuelles? Particulièrement "Interface" pour que l'adresse IP soit disponible sur les 2 WANs? En deuxième question, il nous faut une gateway coté ISP pour joindre notre Pfsense. Faut-il créer une IP virtuelle pour cette gateway ou ajouter une interface ayant comme IP la gateway de l'ISP?


Merci par avance de votre aide,

Nicolas

# - @ - Guillaume - 21/07/2018 à 13:32:16

@GARY :
Bonjour,

Vous pouvez essayer de configurer une autre monitor ip que 9.9.9.9 pour voir si ça change quelque chose à votre problème.
Mais comme je vous l'ai dit dans mon commentaire précédent, ça reste une solution qui n'est pas idéale le fait d'avoir la même gateway sur 2 interfaces différentes (il peut y avoir des effets de bord).
Qui plus est lorsqu'on installe un lien ADSL en back-up d'un lien fibre optique (si c'est bien votre cas), il vaut mieux choisir le choisir chez un opérateur différent ; ça offre une meilleure redondance.

Cordialement,

Guillaume
--
Provya

# - @ - GARY - 20/07/2018 à 16:42:08

@Guillaume :

Bonjour Guillaume,

J'ai appliqué votre solution 1 , à savoir la GW 9.9.9.9 .

Elle fonctionne mais je remarque que l'interface ayant cette Monitor IP subit des déconnexions toutes les 2H environs .


Jul 20 16:32:29 php-fpm /rc.newwanip: MONITOR: ADSL_PPPOE is available now, adding to routing group Groupe_Gateway
9.9.9.9|80.11.80.26|ADSL_PPPOE|15.58ms|0.649ms|0.0%|none

Jul 20 16:32:29 dhcpleases /etc/hosts changed size from original!
Jul 20 16:32:28 dhcpleases Could not deliver signal HUP to process because its pidfile (/var/run/unbound.pid) does not exist, No such process.

Jul 20 16:32:27 php-fpm /rc.newwanip: Removing static route for monitor 9.9.9.9 and adding a new route through 193.253.160.3

Jul 20 16:30:53 ppp [opt1_link0] LCP: LayerDown
Jul 20 16:30:53 ppp [opt1_link0] LCP: SendTerminateReq #62
Jul 20 16:30:53 ppp [opt1] IPV6CP: state change Closed --> Initial
Jul 20 16:30:53 ppp [opt1] IPV6CP: Down event
Jul 20 16:30:53 ppp [opt1] IPCP: state change Closing --> Initial
Jul 20 16:30:53 ppp [opt1] Bundle: No NCPs left. Closing links...
Jul 20 16:30:53 ppp [opt1] IPCP: LayerFinish
Jul 20 16:30:53 ppp [opt1] IPCP: Down event
Jul 20 16:30:53 ppp [opt1] IPV6CP: state change Stopped --> Closed
Jul 20 16:30:53 ppp [opt1] IPV6CP: Close event
Jul 20 16:30:53 ppp [opt1] IFACE: Rename interface pppoe2 to pppoe2
Jul 20 16:30:53 ppp [opt1] IFACE: Down event
Jul 20 16:30:53 check_reload_status Rewriting resolv.conf
Jul 20 16:30:53 ppp [opt1] IPCP: LayerDown
Jul 20 16:30:53 ppp [opt1] IPCP: SendTerminateReq #198
Jul 20 16:30:53 ppp [opt1] IPCP: state change Opened --> Closing
Jul 20 16:30:53 ppp [opt1] IPCP: Close event
Jul 20 16:30:53 ppp [opt1] Bundle: Status update: up 0 links, total bandwidth 9600 bps
Jul 20 16:30:53 ppp [opt1_link0] Link: Leave bundle "opt1"
Jul 20 16:30:53 ppp [opt1_link0] LCP: state change Opened --> Stopping



Est-ce un soucis créé par la Monitor IP "mal acceptée" , ou est-ce un soucis Opérateur ADSL ?

Merci

# - @ - Guillaume - 18/07/2018 à 20:10:13

@jeremy :
Bonjour,

A la lecture de votre message sur le forum, j'ai l'impression que votre besoin est que le trafic du LAN1 sorte avec l'adresse IP FO1 et que le trafic du LAN2 sorte avec l'adresse IP FO2.

Si c'est bien ça votre besoin, alors il est inutile de configurer un dual-wan comme vous l'avez fait. Un seul WAN suffit sur lequel vous renseignez 2 adresses IP (une "physique" et une virtuelle - CARP par exemple) et vous configurez vos règles d'outbound NAT pour que le trafic du LAN1 utilise l'adresse IP FO1 sur l'interface WAN et que le trafic du LAN2 utilise l'adresse IP FO2 sur l'interface WAN.

La consultation de l'article pfSense - configurer un cluster de 2 pfSense redondants (failover) devrait vous renseigner sur la façon de procéder pour configurer les règles d'outbound NAT.

Cordialement,

Guillaume
--
Provya

# - @ - Gary - 18/07/2018 à 16:51:35

@Guillaume :

Merci beaucoup Guillaume ! IT WORKS !

Merci pour votre aide précieuse.


Très cordialement,

# - @ - Guillaume - 18/07/2018 à 16:36:24

@Gary :
Bonjour,

Je vous ai répondu un peu vite. Je n'avais pas noté que vos interfaces étaient en PPPoE.
Vous avez 2 solutions :

1. Vous pouvez modifier la "monitor IP" dans la configuration de l'une de vos gateway (vous pouvez mettre 9.9.9.9 ou 8.8.8.8 par exemple). Ça devrait fonctionner, même si ce n'est pas l'idéal.

2. La gateway vous étant attribuée dynamiquement par votre fournisseur d'accès, vous pouvez essayer de lui demander s'il est possible d'avoir une autre gateway sur l'une des deux connexions.

Cordialement,

Guillaume
--
Provya

# - @ - Gary - 18/07/2018 à 16:07:03

@Guillaume : Merci de votre retour.

Les Gateways de mes interfaces sont gérées Dynamiquement.
Pourquoi sont-elles similaires sur mes 2 interfaces ? comment en attribuer d'autres ?

# - @ - Intra1910 - 18/07/2018 à 14:12:28

@Guillaume :
Merci de ta réponse ! :)

Au final, c'était la passerelle du poste d'un des VLAN qui était mal renseignée ^^

# - @ - Guillaume - 18/07/2018 à 13:58:22

@Intra1910 :
Bonjour,

Vous devriez vérifier la configuration de votre switch (vos vlan sont-ils correctement configurés dessus ?) ainsi que vous ayez bien ajouté une règle de firewall permettant à vos deux vlan de communiquer entre eux.

Si après ces vérifications, ça ne fonctionne toujours pas, je vous invite à poster directement sur le forum officiel pfSense dans la section francophone : https://forum.netgate.com/.

Cordialement,

Guillaume
--
Provya

# - @ - Guillaume - 18/07/2018 à 13:53:08

@Gary :
Bonjour,

Vos 2 interfaces WAN ayant la même gateway, ça ne fonctionnera pas.

Cordialement,

Guillaume
--
Provya